Call Us: 1.877.805.0005

System Requirements

System Requirements

Compatible Devices

You can take our course on any Internet-ready device.

Compatible Browsers

This website was built to conform to the latest web and accessibility standards. Some older web browsers may be incompatible to a lesser or greater degree with these standards. If you have any problems viewing this website as a first step to solving your problem we would please ask you to upgrade your browser if practical.

In general it is best to view this site with the latest version of your favorite browser. As a guide the following popular up-to-date browsers are compatible with this website. They are all free downloads.

Some very important information about the browser settings:

  1. Most of our pages require that Javascript is enabled.
  2. Some of our pages use pop-up windows, so make sure any pop-up killer allows these to be displayed.

Feel free to contact us for further questions.

 
 
Comodo / Authorize.net
Call Us: 1.877.805.0005